pollymc/nix/dev.nix
seth a52574b026
chore(nix): add nil
Signed-off-by: seth <getchoo@tuta.io>
2023-05-27 19:25:49 -04:00

47 lines
965 B
Nix

{
inputs,
self,
...
}: {
perSystem = {
system,
pkgs,
...
}: {
checks = {
pre-commit-check = inputs.pre-commit-hooks.lib.${system}.run {
src = self;
hooks = {
markdownlint.enable = true;
alejandra.enable = true;
deadnix.enable = true;
nil.enable = true;
clang-format = {
enable =
false; # As most of the codebase is **not** formatted, we don't want clang-format yet
types_or = ["c" "c++"];
};
};
};
};
devShells.default = pkgs.mkShell {
inherit (self.checks.${system}.pre-commit-check) shellHook;
packages = with pkgs; [
nodePackages.markdownlint-cli
alejandra
deadnix
clang-tools
nil
];
inputsFrom = [self.packages.${system}.default];
buildInputs = with pkgs; [ccache ninja];
};
formatter = pkgs.alejandra;
};
}